Skip to content

Excel: Wert aus einer Tabelle lesen

Ich möchte hier mal kurz auf zwei Möglichkeiten eingehen, wie man in Excel für die weitere Bearbeitung einen Wert aus einer Tabelle auslesen kann.

Möglichkeit 1: eine Abhängigkeit

Man hat eine Liste, in der es nur eine Abhängigkeit gibt, in diesem Fall die Artikelnummer…

hier fehlt leider eine Tabelle

In A2 gibt man also seine Artikelnummer ein und Excel soll in B2, C2 und D2 die jeweils zugehörigen Eigenschaften auflisten für die weitere Verwendung. Das lässt sich zum Glück mit einem ganz einfachen Befehl machen.

=SVERWEIS(Suchkriterium;Matrix;Spaltenindex)

In B2 müsste dann stehen:

=SVERWEIS(A2;A4:D6;2)

In C2 müsste dann stehen:

=SVERWEIS(A2;A4:D6;3)

In D2 müsste dann stehen:

=SVERWEIS(A2;A4:D6;4)

Sobald man also in A2 eine gültige Artikelnummer eingibt, werden die entsprechenden Eigenschaften in den anderen Zellen angezeigt.

Schwieriger wird es jedoch im nächsten Fall…

Möglichkeit 2: zwei Abhängigkeiten

Im folgenden Beispiel hat man z. B. die Anzahl der Schüler aus den Jahren 2001 bis 2003 und den Klassen a-c in eine Tabelle eingetragen. Nun möchte man Anhand des Jahrgangs und der Klasse wissen wie viele Schüler dort waren.

hier fehlt leider eine Tabelle

Leider gibt es meines Wissens in Excel dafür keinen Befehl, aber man kann sich auch anderweitig helfen.

Dafür braucht man die Makros VERGLEICH, ZEICHEN und INDIREKT. Was die Befehle im Einzelnen machen, kann man in der Hilfe gerne selber nachschauen wink

Zuerst einmal muss man herausfinden, in welcher Spalte und Zeile gesucht werden muss.

Für die Zeile:

=VERGLEICH(B1;A5:A7)

Für die Spalte:
bc. =VERGLEICH

In unserem Beispiel sollte jetzt für die Zeile 2 und für die Spalte 3 als Ergebnis erscheinen. Damit kann man aber erstmal noch nicht so viel anfangen.

Zuerst einmal muss man sich noch das Ergebnis für die Spalte in einen Buchstaben umwandeln lassen, damit man das übliche A-z-Schema hat. Der Einfachheit halber kann man die obige Formel direkt erweitern.

=ZEICHEN(VERGLEICH(B2;B4:D4)+1+64)

Wichtig zu beachten sind die beiden Additionswerte am Ende der Klammer. Die +1 benötigt man, da im Ergebnis ja eine 3 stand, dies aber in Wirklichkeit die 4te Spalte ist. Hier muss man also wenn nötig etwas anpassen und ausprobieren. Die +64 werden wegen der Kodierung benötigt, damit man auch wirklich die üblichen Buchstaben erhält.

Die Formel für die Zeile muss man auch noch etwas anpassen, da sich unsere gewünschte Zeile nicht in 2 befindet, sondern etwas weiter unten…

Für die Zeile also nun:

=VERGLEICH(B1;A5:A7)+4

Als Ergebnis sollte jetzt für die Spalte D erscheinen und für die Zeile 6. Damit sind wir schon ein ganzes Stück weiter laugh

Zu guter Letzt muss man muss man diese beiden Formeln oder Ergebnisse noch dazu verwenden, den Wert aus der Tabelle lesen zu lassen.

=INDIREKT(ZEICHEN(VERGLEICH(B2;B4:D4)+1+64)&VERGLEICH(B1;A5:A7)+4)

Wie man sieht, werden die beiden einzelnen Formeln einfach mit einem UND verknüpft und als Parameter an den Befehl INDIREKT übergeben.

Als Ergebnis der Formel sollte nun in B3 als Ergebnis die gesuchte 11 erscheinen. Wenn man dann noch mit ein paar Arbeitsblättern und Tabellenbereichen arbeitet, kann natürlich auch so etwas wie hier entstehen :whistle:

Damit ist unser heutiger kleiner Excel-Kurs beendet wink

Trackbacks

Keine Trackbacks

Kommentare

Ansicht der Kommentare: Linear | Verschachtelt

Noch keine Kommentare

Kommentar schreiben

Standard-Text Smilies wie :-) und ;-) werden zu Bildern konvertiert.
Textile-Formatierung erlaubt
Die angegebene E-Mail-Adresse wird nicht dargestellt, sondern nur für eventuelle Benachrichtigungen verwendet.
Um einen Kommentar hinterlassen zu können, erhalten Sie nach dem Kommentieren eine E-Mail mit Aktivierungslink an ihre angegebene Adresse.
:'(  :-)  :-|  :-O  :-(  8-)  :-D  :-P  ;-) 
Wenn Du Deinen Twitter Namen eingibst wird Deine Timeline in Deinem Kommentar verlinkt.
Bewirb einen Deiner letzten Artikel
Dieses Blog erlaubt Dir mit Deinem Kommentar einen Deiner letzten Artikel zu bewerben. Bitte gib Deine Blog URL als Homepage ein, dann wird eine Auswahl erscheinen, in der Du einen Artikel auswählen kannst. (Javascript erforderlich)
Formular-Optionen
tweetbackcheck